Error in index page

Having trouble installing ModphpBB3 - Post any questions or issues in here.
  • Advertisement

Bookmark and Share

Error in index page

Postby Anggun » Sun Feb 01, 2009 3:11 pm

I'm trying to install ModphpBB3 1.0.5 Beta and followed the usual instructions to a T.

But when I get to the index page, I keep getting this error.

Code: Select all
Fatal error: Call to undefined method user::format_dateucb() in /home/tlgimsco/domains/ogphu.co.cc/public_html/includes/functions_upcbirthdays.php on line 91


All other pages are fine. I think it has something to do with the upcoming birthdays at the bottom of the index page but I can't figure what is wrong.
User avatar
Anggun
Forum Member
Forum Member
 
Posts: 15
Joined: July 2008
Has thanked: 0 time
Have thanks: 0 time

Re: Error in index page

Postby LDM » Sun Feb 01, 2009 7:27 pm

Is it a convertion or fresh install?
Image

Image
User avatar
LDM
Site Admin
Site Admin
 
Posts: 1794
Joined: May 2008
Location: UK
Has thanked: 17 times
Have thanks: 122 times
Fine

Re: Error in index page

Postby Anggun » Mon Feb 02, 2009 1:18 am

Fresh install.
User avatar
Anggun
Forum Member
Forum Member
 
Posts: 15
Joined: July 2008
Has thanked: 0 time
Have thanks: 0 time

Re: Error in index page

Postby LDM » Mon Feb 02, 2009 2:04 am

There could be a few things to try as I haven't seen that error on a fresh install before.

Double check the table is added in Database, if not, run this in there:
Code: Select all
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_birthdays_ahead', '7');


Also, you could disable it within ACP. Can't really remember the settings you need to adjust (it's late :D ) but it is down there in 'load settings' area if I remember right.

Final straw, delete the template include to see if index loads again. Open index_body.html and delete:
Code: Select all
<br /><!-- IF BIRTHDAYS_AHEAD_LIST -->{L_BIRTHDAYS_AHEAD}: <strong>{BIRTHDAYS_AHEAD_LIST}</strong><!-- ENDIF -->
Image

Image
User avatar
LDM
Site Admin
Site Admin
 
Posts: 1794
Joined: May 2008
Location: UK
Has thanked: 17 times
Have thanks: 122 times
Fine

Re: Error in index page

Postby Anggun » Mon Feb 02, 2009 2:40 am

LDM wrote:There could be a few things to try as I haven't seen that error on a fresh install before.

Double check the table is added in Database, if not, run this in there:
Code: Select all
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_birthdays_ahead', '7');


THank you.. This one worked. The table row had an initial value of 365... Deleted it and insert the above and it worked.

I was going crazy trying to figure out what when wrong, did I missed a file to upload. Thank goodness its not a conversion or else my members will be stranded.
User avatar
Anggun
Forum Member
Forum Member
 
Posts: 15
Joined: July 2008
Has thanked: 0 time
Have thanks: 0 time

Re: Error in index page

Postby LDM » Mon Feb 02, 2009 12:31 pm

I'm glad you got it sorted Anggun. It doesn't normally throw that errow and haven't seen any report other than this one on it, so could be something server-side.

Nevermind, it's all running now which is the main thing.
Image

Image
User avatar
LDM
Site Admin
Site Admin
 
Posts: 1794
Joined: May 2008
Location: UK
Has thanked: 17 times
Have thanks: 122 times
Fine

Re: Error in index page

Postby Anggun » Sun Feb 15, 2009 2:38 pm

Okay, is there another way around this?
Since the upcoming birthday is set to 7 days ahead, I found that if someone has a birthday in the next 7 days, I got the same error again..
So basically I can't use that feature at all.
Kinda sad.. my members love that feature.

About that it could be server side, I don't know though I tried it on my localhost and got the same error.
User avatar
Anggun
Forum Member
Forum Member
 
Posts: 15
Joined: July 2008
Has thanked: 0 time
Have thanks: 0 time

Re: Error in index page

Postby LDM » Sun Feb 15, 2009 2:44 pm

What style are you using?
Image

Image
User avatar
LDM
Site Admin
Site Admin
 
Posts: 1794
Joined: May 2008
Location: UK
Has thanked: 17 times
Have thanks: 122 times
Fine

Re: Error in index page

Postby Anggun » Sun Feb 15, 2009 2:44 pm

Prosilver
User avatar
Anggun
Forum Member
Forum Member
 
Posts: 15
Joined: July 2008
Has thanked: 0 time
Have thanks: 0 time

Re: Error in index page

Postby LDM » Sun Feb 15, 2009 4:30 pm

hmm, it sounds like something server related. Can you see if the edit is at the bottom of index_body.html.
Image

Image
User avatar
LDM
Site Admin
Site Admin
 
Posts: 1794
Joined: May 2008
Location: UK
Has thanked: 17 times
Have thanks: 122 times
Fine

Next


  • Advertisement

Return to ModphpBB3 Installation



Who is online

Users browsing this forum: No registered users and 4 guests


Subscribe to the ModphpBB3 Forum RSS